2.3.1 Veraltete Datenbanken

Im Laufe der Entwicklung von Mahaf (vormals GWlinks) musste ich einige Male das Datenbankvormat so stark geändert, dass ältere Datenbanken nicht mehr mit neueren Versionen der Software geöffnet werden konnten.
Meist ist dies bei großen Änderungen an der Datenbankstruktur geschehen.
Eine Inkompatibilität war leider nicht immer zu vermeiden.

Vor 0.6.8 und früher (vor dem 08.01.2006)
Sollte noch eine Datenbank existieren, die zuletzt mit einer Mahaf-Version früher als 0.6.9 (veröffentlicht am 08.01.2006) bearbeitet wurde, dann kann diese ab der Version 0.7.4 (veröffentlicht am 20.05.2006) nicht mehr geöffnet werden.

Die Versionen zwischen 0.6.9 und 0.7.3 können beide Datenbankversionen öffnen, speichern aber nur noch die Neue.

Um betreffende Datenbanken mit einer aktuellen Anwendung öffnen zu können muss man sich daher die Version 0.7.3 installieren (ggf. mobil), mit dieser die Datenbank öffnen und mindestens einmal abspeichern.
Danach kann die Datenbank dann weiter verwendet werden.